Opened 2 years ago

Closed 21 months ago

#985 closed defect (fixed)

Saving Project Fails

Reported by: lewis Owned by: krzywon
Priority: major Milestone: SasView 4.2.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

If you load in some data and send it to a perspective (other than fitting), then go to File→Save Project and try to save, you get an error message saying "NoneType object has no attribute firstChild" (see attached screenshot).
If data is first sent to the fitting perspective, then to another perspective before attempting to save, a different error message is shown (see other attached screenshot)

Attachments (2)

Error 1.PNG (13.7 KB) - added by lewis 2 years ago.
Error message shown when data is sent to a pespective (other than fitting)
Error 2.PNG (19.6 KB) - added by lewis 2 years ago.
Error message shown when data is sent to fitting, then to another perspective

Download all attachments as: .zip

Change History (10)

Changed 2 years ago by lewis

Error message shown when data is sent to a pespective (other than fitting)

Changed 2 years ago by lewis

Error message shown when data is sent to fitting, then to another perspective

comment:1 Changed 2 years ago by krzywon

I believe this is a duplicate of #960 where any empty fit pages throw errors. I tested this in the 4.1.1 release and saving and loading a project with no fits worked. The fix for this is not in master yet, and is waiting for the 4.1.2 release to be finalized which is why it is still likely occurring.

comment:2 Changed 23 months ago by lewis

Sending data to fitting, then another perspective, then saving now works. However, loading in the save file created fails.

Sending data to a perspective other than fitting then saving the project still throws an error

comment:3 Changed 22 months ago by krzywon

  • Owner set to krzywon
  • Status changed from new to assigned

comment:4 Changed 22 months ago by krzywon

This was a different issue than #960. The new reader infrastructure was breaking the loading of projects. I applied a fix in pull request 94, 4.1 issues, after resolving the conflicts with master.

comment:5 Changed 22 months ago by butler

  • Resolution set to fixed
  • Status changed from assigned to closed

This particular error is fixed in PR 94. There may (probably still are) saving issues remaining

comment:6 Changed 22 months ago by krzywon

  • Resolution fixed deleted
  • Status changed from closed to reopened

Opening a save state that only has a p(r) is still throwing an error. I am reopening this ticket.

comment:7 Changed 22 months ago by krzywon

In 7b07fbe306fb8a4fe61838f12a869394e2e47c0a/sasview:

Move generic loading functions from cansas_reader into file_reader_base_class. Cascade changes to other readers. refs #985

comment:8 Changed 21 months ago by krzywon

  • Resolution set to fixed
  • Status changed from reopened to closed

PR109 had work to solve the saving/loading issue.

Note: See TracTickets for help on using tickets.