Opened 4 years ago

Closed 4 years ago

#986 closed defect (fixed)

Send to fitting overwrites theory page even if blank FitPage has focus

Reported by: butler Owned by: lewis
Priority: major Milestone: SasView 4.2.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

This problem was reported by Steve King while he was attempting to reproduce problem reported in ticket #943

Basically, data that is "sent to fitting" always populates the first fit page without an associated data set regardless of whether it is completely fresh or in fact is a theory page and even if there is another FitPage open with no corresponding theory yet and which has focus.

This was introduced in 4.1. In 4.01 data seems to be sent to the currently active FitPage tab. I think the desired behavior is probably that in 4.01 but should be discussed. The consequence of the current behavior is that one cannot have a theory only page and then load a file to a separate page since the theory page will be considered "empty" and be populated by the data being loaded.

Regardless of the "correct behavior," the current behavior is "accidental" in that it throws an error which I think is due to it finding 2 fitpages without data and thus the "ambiguity" in which should get the data (clearly what it does with the error is that it chooses the lowest number fit page). The error thrown is;

2017-08-05 12:00:03,273 : ERROR : sas.sasgui.guiframe.local_perspectives.plotting.Plotter1D (Plotter1D.pyc:259) :: The truth value of an array with more than one element is ambiguous. Use a.any() or a.all()
2017-08-05 12:00:03,273 : ERROR : sas.sasgui.guiframe.local_perspectives.plotting.Plotter1D (Plotter1D.pyc:259) :: The truth value of an array with more than one element is ambiguous. Use a.any() or a.all()

Change History (2)

comment:1 Changed 4 years ago by lewis

  • Owner set to lewis
  • Status changed from new to assigned

comment:2 Changed 4 years ago by lewis

  • Resolution set to fixed
  • Status changed from assigned to closed

In 6f9abd39b6d696038bf298ef8e8b277439a2cb9c/sasview:

Don't send data to fit panel if it has an active theory and is in bg

Fixes #986

Note: See TracTickets for help on using tickets.