Opened 19 months ago

Last modified 2 months ago

#885 assigned defect

New Model Editor needs to properly deal with form_volume function

Reported by: ajj Owned by: gonzalezm
Priority: critical Milestone: SasView 4.3.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

The 'New Model Editor' allows you to specify parameters which are polydisperse and which are then marked as 'volume' parameters in the resulting code.

However, because form_volume still returns 1.0 by default, the weighting of the polydispersity is probably wrong.

This GUI should require the user to define form_volume if polydisperse parameters are requested.

Change History (4)

comment:1 Changed 8 months ago by butler

  • Priority changed from major to critical

comment:2 Changed 8 months ago by butler

  • Owner set to gonzalezm
  • Status changed from new to assigned

comment:3 Changed 4 months ago by butler

  • Milestone changed from SasView 4.2.0 to SasView 4.3.0

This code has now been reverted to not support any polydispersity so that at least an easy model will be created correctly for release 4.2. branch 885 remains to work on fixing the editor to use polydispersity correctly but the ticket is moving to 4.3

comment:4 Changed 2 months ago by butler

The problems were almost surely due to the problems documented in ticket #1142 which should be fixed in 4.2.0. This branch can then be revived and merged.

Note: See TracTickets for help on using tickets.