Opened 3 years ago

Closed 3 years ago

#884 closed defect (fixed)

Report Results is not appending .pdf to file name

Reported by: smk78 Owned by:
Priority: blocker Milestone: SasView 4.1.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

Testing Win7 local build and ESS Jenkins 4.1 Build 165:

Report Results generates a zero-length file unless you specifically add .pdf to the filename, even though the default Save as Type is pdf!

This just caused me some frustration; there will be much wailing in the user community if it's not rectified!

Selecting the alternative Save as Types of .txt or .html works as expected (ie, you don't need to add the descriptor manually).

Change History (7)

comment:1 Changed 3 years ago by krzywon

Is this a duplicate of #818?

comment:2 Changed 3 years ago by smk78

Appears to have a similar impact on the Report as #818, but the cause seems much more straightforward (ie, not a missing dependency, simply a missing file extension)!

comment:3 Changed 3 years ago by krzywon

https://github.com/xhtml2pdf/xhtml2pdf/pull/301
https://github.com/xhtml2pdf/xhtml2pdf/blob/master/CHANGELOG.txt

What version of xhtml2pdf are you using? This should be fixed as of xhtml2pdf v0.1alpha4.

comment:4 Changed 3 years ago by smk78

check_packages says:
xhtml2pdf Version Installed: 3.0.33

comment:5 Changed 3 years ago by krzywon

I would suggest upgrading to the latest version of xhtml2pdf and see if that

  • Download the wheel file (.whl) from https://pypi.python.org/pypi/xhtml2pdf#downloads and remember where you saved it.
  • Open a command prompt and navigate to the location you saved the wheel to.
  • (if you don't have pip) easy-install pip
  • pip unistall xhtml2pdf
  • pip install <xhtml2pdf wheel file name> - you should be able to tab complete the file name
  • Try saving the pdf again and see what happens.

This might be another package dependency issue that should be addressed in #681 and #886.

comment:6 Changed 3 years ago by smk78

Ok. Followed these instructions and they seem to have done the trick! Though the wheel I picked up seems to be a beta…

check_packages now says:
xhtml2pdf Version Installed: 0.2b1

comment:7 Changed 3 years ago by smk78

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.