Opened 2 years ago

Closed 21 months ago

#856 closed defect (fixed)

Reading SAS_OPENCL from custom_config sometimes raises an ERROR

Reported by: wojciech Owned by: krzywon
Priority: major Milestone: SasView 4.2.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

Paul K and Jeff experienced problem reading custom_config.py©. This seems to occur when switiching between git branches.
It is difficult to reporduce as sasview writes to this file when finishing session.

The bug is related to end of line.
ERROR Error loading /Users/pkienzle/.sasview/config/custom_config: EOF read where object expected

Change History (9)

comment:1 Changed 2 years ago by wojciech

  • Owner set to wojciech
  • Status changed from new to assigned

comment:2 Changed 2 years ago by butler

I have recently had the same problem I think. Had not yet reported as I thought it was due to something wrong with my local installation. I realize it started happening when I started working with different branches (from within eclipse). I eventually figured out that by deleting the custom_config.pyc the system returned to normal. The error reported in the log file is

2017-02-20 19:49:59,832 ERROR Error loading C:\Users\Paul\.sasview\config/custom_config: bad marshal data (unknown type code)
2017-02-20 19:49:59,834 INFO GuiManager loaded C:\Users\Paul\.sasview\config/custom_config
2017-02-20 19:49:59,834 ERROR Error loading C:\Users\Paul\git\sasview_new/custom_config: No module named custom_config
2017-02-20 19:49:59,835 INFO GuiManager loaded C:\Users\Paul\git\sasview_new/custom_config
2017-02-20 19:49:59,835 INFO Custom_config file was not imported

Looking up the "bad marshal data" error it is apparently due to a "corrupt .pyc file" hence the clue that deleting custom_config.pyc would fix the problem.

On the other hand this seems like a developer system issue and one that only hits people advanced enough to be poking around branches? if the solution is to delete the pyc file after switching that is annoying to developers but I do not see how it is an issue for a 4.1 release?

If I am correct then I think we should move this to a future release?

comment:3 Changed 2 years ago by wojciech

Yes, it seems to be the same problem that occurs when switching branches but also probably only once. What I mean I cannot reproduce this error when I switch branches again. It is also true that it only affects developers enviroment.

I am ok with moving it to 4.2 but I will try to resolve it soon anyway.

comment:4 Changed 2 years ago by wojciech

Trying hard to reproduce this error both on osx and windows and and cannot.
It seems that this either magically been fixed or occurs only once when switching between git branches. In my opinion we can close this ticket and monitor if this issue reoccurs.

comment:5 Changed 2 years ago by wojciech

Paul K. and Jeff still observe this issue, so probably still needs to be look into.

comment:6 Changed 2 years ago by butler

  • Milestone changed from SasView 4.1.0 to SasView 4.2.0

Agree with Wojciech: We should move this to 4.2 at this point but keep it open. It is not in any way an issue affecting the release executable and clearly a subtle issue. Any time available to work on SasView at this point would probably be better used closing tickets that are required for the release.

comment:7 Changed 2 years ago by krzywon

  • Owner changed from wojciech to krzywon
  • Status changed from assigned to accepted

I took a brief look into the issue reported by Lennart Lindfors (View→Startup Settings causing issues), I think the issue is related to this ticket. The SAS_OPENCL flag does not get any line ending applied, so any new lines are appended to the end of it.

I'm taking this and will submit a pull request shortly.

comment:8 Changed 2 years ago by wojciech

I think Jeff solved this issue. We probably just need to close this ticket.

comment:9 Changed 21 months ago by butler

  • Resolution set to fixed
  • Status changed from accepted to closed

Talking to Jeff we think that indeed this is now fixed so closing this ticket finally

Note: See TracTickets for help on using tickets.