Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#750 closed defect (fixed)

P(q)*S(q) not doing the right thing

Reported by: ajj Owned by: ajj
Priority: blocker Milestone: SasView 4.1.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

(1) Problem with radius_effect appearing - name change on model is the cause.

(2) Extra scale appearing that shouldn't - coming from P(q), but isn't supposed to show up

(3) Background appears to be being multiplied by scale_factor

(4) Behaviour is wrong when P(q) nominally goes to 1 - getting 0 as result

Change History (6)

comment:1 Changed 5 years ago by ajj

Looks like MultiplicationModel?.py is doing:

scale_factor * [P(q)+bkd]*S(q)

should be doing

scale_factor*P(q)*S(q)+bkd

comment:2 Changed 5 years ago by pkienzle

sasmodels.product should be a replacement for MultiplicationModel. Incorporate that into sasview rather than fixing MultiplicationModel, as per Ticket #548.

comment:3 Changed 5 years ago by ajj

  • Resolution set to fixed
  • Status changed from new to closed

In fd62331a2d3189e76b6046c10a411463ce7e9641/sasview:

Updating muliplicationmodel to be correct.

Fixes #750

comment:4 Changed 5 years ago by ajj

In 68669da9154d53fe949cb741efa850cd516ce157/sasview:

Updating MultiplicationModel? to deal with results of fixing #657.

Fixes #750 (again)

comment:5 Changed 5 years ago by ajj

In c5a22a8553ed868bd3d5fd17df0b9f823de4d30c/sasview:

Updating muliplicationmodel to be correct.

Fixes #750

comment:6 Changed 5 years ago by ajj

In 736f27e9e612490fce2428fe33d9f38530134575/sasview:

Updating MultiplicationModel? to deal with results of fixing #657.

Fixes #750 (again)

Note: See TracTickets for help on using tickets.