Opened 13 months ago

Closed 5 weeks ago

#741 closed defect (fixed)

Recalculate P(Q) and S(Q) components on model update.

Reported by: richardh Owned by: lewis
Priority: blocker Milestone: SasView 4.2.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

If the new theory S(Q) is appended to a plot, it does not change when performing fits until you append again.

Can we have it to auto-update please, likewise P(Q) etc.

Change History (12)

comment:1 Changed 12 months ago by butler

  • Milestone changed from SasView 4.1.0 to SasView 5.0.0

As discussed at Tuesday's meetig (Oct 25), actually this is a function of the way GuiFrame works: All theory "data" behaves this same way. Mainly the underlying theory data will change and the plot that is generated at the same time as that data is updated BUT ... if one goes the other way by sneding such a "data" to "New Plot" from the data explorer it is done via a copy of the data. That copy does not change and is therefore there is nothing to update. I believe the use of copy was because trying to make the plot just another view onto the same data (which is what it should be) caused a lot of other problems.

With the 5.0 GUI refactoring this is probably best left for that release and added to the tickets for the ESS branch to be considering in the refactor)

comment:2 Changed 12 months ago by butler

  • Owner changed from mathieu to piotr
  • Status changed from new to assigned

comment:3 Changed 8 months ago by smk78

ESS Jenkins Win7 Build 640:

If you are fitting:
The first time you plot or append the P(Q) & S(Q) theories you get something sensible. But thereafter, no matter what you do to change P(Q) or S(Q), whether you select append or new plot, you only get the same (original) traces for P(Q) or S(Q). The combined MODEL trace changes, so P(Q) and S(Q) are being recalculated, but the individual component THEORIES are not being updated.

If you are simulating (computing); ie, you ONLY have THEORIES, no data:
You cannot display P(Q) or S(Q) at all. All you get is the error

Plotting Error: Plottable.View: Given y and x are not of the same length

comment:4 Changed 7 months ago by ajj

  • Milestone changed from SasView 5.0.0 to SasView 4.1.0
  • Owner changed from piotr to mathieu
  • Priority changed from major to blocker
  • Summary changed from can we auto-update S(Q) etc if appended to a plot? to Recalculate P(Q) and S(Q) components on model update.

Plottting error is gone, but the separated components are not updated (#904 was duplicate of this ticket).

Why was this not a blocker for 4.1? The plotting of P(Q) and S(Q) was a requirement for this release but does not work properly.

If the items were updated then the plots will update.

comment:5 Changed 7 months ago by GitHub <noreply@…>

  • Resolution set to fixed
  • Status changed from assigned to closed

In 4c5098cac470ea0a367a8f92be0ed0ac428bcc12/sasview:

Fixes #741 Remove P(Q), S(Q) feature

comment:6 Changed 7 months ago by GitHub <noreply@…>

In 7cbbacd529c94fa76210aac262ae611bba6b05cf/sasview:

Merge pull request #57 from SasView?/741_PS_fix

Fixes #741 Remove P(Q), S(Q) feature

comment:7 Changed 7 months ago by ajj

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:8 Changed 7 months ago by ajj

  • Milestone changed from SasView 4.1.0 to SasView 4.2.0

comment:9 Changed 6 months ago by butler

In 24b382118c3145d493e1f76e2b308e6aa6f0759c/sasview:

re-enable calculation/separation of P & S in SasView? (appearing under
the model they fit or in theory as appropriate) addresses #741

comment:10 Changed 3 months ago by butler

  • Owner changed from mathieu to butler
  • Status changed from reopened to assigned

comment:11 Changed 8 weeks ago by butler

  • Owner changed from butler to lewis

Lewis has taken this over so changing assignment

comment:12 Changed 5 weeks ago by lewis

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.