#706 closed defect (fixed)

testing custom models - issues?

Reported by: richardh Owned by: pkienzle
Priority: minor Milestone: SasView 4.1.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description (last modified by butler)

Trying to follow manual "Writing a plugin model" to add a model (actually a needed reparametrisation of hollow_cylinder, see #675)

Please make the "info" box on "check model" results larger, as I had to copy & paste the output elsewhere to make sense of it.

After successful compile, is there a bug in:

run_one("c:/users/rkh98/.sasview/plugin_models/hollow_cylinder_new.py")
Traceback (most recent call last):
  File "<input>", line 1, in <module>
  File "C:\stfc\sasview4\sasmodels\sasmodels\model_test.py", line 293, in run_one
    if not suite._tests[0].info.tests:
IndexError: list index out of range

or was it an issue with my new model?

If you don't have openCL then the default "main()" test fails, could say how to get around this. I can get it to work with the openMP version:

main("-single!","-double!", "c:/users/rkh98/.sasview/plugin_models/hollow_cylinder_new.py")

Would be useful if manual said that ctrl/uparrow gets previous line back in python shell.

Change History (6)

comment:1 Changed 14 months ago by butler

  • Description modified (diff)

comment:2 Changed 14 months ago by Paul Kienzle <pkienzle@…>

In 3c852d4604cf51f0fd434203b6ffb125dc07e927/sasmodels:

use public api to access test suite (refs #706)

comment:3 Changed 14 months ago by pkienzle

I couldn't reproduce the error, but I posted a change that should fix it.

Please try again, and attach the file that was causing problems.

I'm leaving the ticket open until it is tested, and until the second part of the ticket (the request to update the docs) has been addressed.

comment:4 Changed 14 months ago by pkienzle

See #748 for attached models.

comment:5 Changed 14 months ago by pkienzle

No longer fails, but claims there are no tests if sasmodels.core.HAVE_OPENCL = False

comment:6 Changed 14 months ago by Paul Kienzle <pkienzle@…>

  • Resolution set to fixed
  • Status changed from new to closed

In 479d0f3037754800fa16a1958b2bdbe5fe7b20b8/sasmodels:

run_one() uses dll if OpenCL is not available. Fixes #706.

Note: See TracTickets for help on using tickets.