Opened 4 years ago

Closed 4 years ago

#401 closed defect (fixed)

easy sum custom model broken

Reported by: pkienzle Owned by: butler
Priority: blocker Milestone: SasView 3.1.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

the dialog for easy sum custom model does not allow name or description to be entered (Windows) or anything to be entered (Mac).

Change History (5)

comment:1 Changed 4 years ago by butler

Hummm works "fine" for me on both mac and PC. I used the builds from ESS available 8PM US EDT on April 2, 2015.

However I found 2 other problems:

1) the panel has NO scrollbar - thus on my small laptop I could never reach the "apply" button and thus thwarted from saving the function

2) when applying a nonsense function no error was displayed yet no function was generated — though this should be tested more thoroughly (only did once then came back and typed reasonable equation and all worked fine. In fact in that case the apply button generated a message that it was succesful and how to access the function.

comment:2 Changed 4 years ago by butler

correction to 2 above. The problem is when using a space in the function name. a red "error" appears under the panel on left side but no indication of problem. Worse, if you hit apply again it now says "name already exists." this logic is probably also wrong on PC but needs to be tested once scroll panel is added. Actual non functional code generates pop ups describing the problem.

comment:3 Changed 4 years ago by butler

Ooops … was looking at custom model not "sum" above description applies to custom only — will generate new ticket. Sum model is broken as described - my bad!

comment:4 Changed 4 years ago by butler

  • Owner set to butler
  • Priority changed from major to blocker
  • Status changed from new to accepted

comment:5 Changed 4 years ago by butler

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed the main problem along with some niggles. Still could use a bit more refactoring but good enough probably till we refactor for new models.

Note: See TracTickets for help on using tickets.