Opened 6 months ago

Last modified 6 months ago

#1249 new defect

use backslash correctly in strings

Reported by: pkienzle Owned by:
Priority: minor Milestone: SasView 4.3.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

Python 3 warning from sasview:

src/sas/sasgui/plottools/PlotPanel.py:1158
  .../src/sas/sasgui/plottools/PlotPanel.py:1158: DeprecationWarning: invalid escape sequence \%
    if label_temp.count("\%s" % "\\") > 0:

src/sas/sasgui/plottools/PlotPanel.py:1793
  .../src/sas/sasgui/plottools/PlotPanel.py:1793: DeprecationWarning: invalid escape sequence \l
    self.graph._xaxis_transformed("\ln{(%s)}" % xname, "%s" % xunits)

src/sas/sasgui/plottools/PlotPanel.py:1805
  .../src/sas/sasgui/plottools/PlotPanel.py:1805: DeprecationWarning: invalid escape sequence \l
    self.graph._yaxis_transformed("\ln{(%s)}" % yname, "%s" % yunits)

src/sas/sasgui/plottools/PlotPanel.py:1824
  .../src/sas/sasgui/plottools/PlotPanel.py:1824: DeprecationWarning: invalid escape sequence \ 
    self.graph._yaxis_transformed("%s \ \ %s^{2}" % (yname, xname),

src/sas/sasgui/plottools/PlotPanel.py:1829
  .../src/sas/sasgui/plottools/PlotPanel.py:1829: DeprecationWarning: invalid escape sequence \ 
    self.graph._yaxis_transformed("%s \ \ %s^{4}" % (yname, xname),

src/sas/sasgui/plottools/PlotPanel.py:1835
  .../src/sas/sasgui/plottools/PlotPanel.py:1835: DeprecationWarning: invalid escape sequence \s
    self.graph._yaxis_transformed("1/\sqrt{%s}" % yname,

src/sas/sasgui/plottools/PlotPanel.py:1839
  .../src/sas/sasgui/plottools/PlotPanel.py:1839: DeprecationWarning: invalid escape sequence \l
    self.graph._yaxis_transformed("\ln{(%s \ \ %s)}" % (yname, xname),

src/sas/sasgui/plottools/PlotPanel.py:1844
  .../src/sas/sasgui/plottools/PlotPanel.py:1844: DeprecationWarning: invalid escape sequence \l
    self.graph._yaxis_transformed("\ln (%s \ \ %s^{2})" % (yname, xname),

src/sas/sasgui/plottools/PlotPanel.py:1849
  .../src/sas/sasgui/plottools/PlotPanel.py:1849: DeprecationWarning: invalid escape sequence \l
    self.graph._yaxis_transformed("\ln (%s \ \ %s^{4})" % (yname, xname),

src/sas/sasgui/plottools/PlotPanel.py:1855
  .../sas/sasgui/plottools/PlotPanel.py:1855: DeprecationWarning: invalid escape sequence \ 
    self.graph._yaxis_transformed("%s \ \ %s^{4}" % (yname, xname),

Change History (1)

comment:1 Changed 6 months ago by Paul Kienzle <pkienzle@…>

In 34f23c81aa61f99e9fa067689ac823e11cfecde3/sasview:

py3/wx4 compatibility changes for gui. Refs #1249

Note: See TracTickets for help on using tickets.