Opened 3 years ago

Closed 3 years ago

#978 closed defect (fixed)

load project fails for pages which have not been defined

Reported by: pkienzle Owned by:
Priority: major Milestone: SasView 4.2.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

To reproduce:

  • load the test/1d_data/latex_smeared.xml,
  • send to fitting,
  • fit the first dataset to a sphere model (start radius at 2000),
  • do not touch the second fit page
  • save project
  • restart sasview
  • load project
18:54:06 - ERROR : sas.sasgui.guiframe.gui_statusbar:  80: 2017-06-19 18:54:06 : Error: This model state has missing or outdated information.
Traceback (most recent call last):
  File "/Users/pkienzle/Source/sasview-new/src/sas/sasgui/perspectives/fitting/fitpage.py", line 2028, in reset_page
    self.reset_page_helper(state)
  File "/Users/pkienzle/Source/sasview-new/src/sas/sasgui/perspectives/fitting/basepage.py", line 1160, in reset_page_helper
    state._convert_to_sasmodels()
  File "/Users/pkienzle/Source/sasview-new/src/sas/sasgui/perspectives/fitting/pagestate.py", line 477, in _convert_to_sasmodels
    self._old_first_model()
  File "/Users/pkienzle/Source/sasview-new/src/sas/sasgui/perspectives/fitting/pagestate.py", line 401, in _old_first_model
    self.formfactorcombobox = FIRST_FORM[self.categorycombobox]
KeyError: 'Cylinder'

Saved project file is attached

Attachments (1)

_latex_fit_report.svs (83.6 KB) - added by pkienzle 3 years ago.

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by pkienzle

comment:1 Changed 3 years ago by krzywon

Looking at the save file, the 2nd data set should have never been saved. No model was selected. The project loads, but throws an error because no model was available. The 4_1_issues branch now has a fix for saving the projects.

comment:2 Changed 3 years ago by butler

  • Resolution set to fixed
  • Status changed from new to closed

fixed by PR 94

Note: See TracTickets for help on using tickets.