Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#804 closed defect (fixed)

rename sas library functions

Reported by: pkienzle Owned by: wojciech
Priority: major Milestone: SasView 4.1.0
Component: sasmodels Keywords:
Cc: Work Package: SasView Bug Fixing


Improve names of sas library functions so that it is easier for the reader to identify what they do. Suggested names:

sph_j1c ⇒ sas_3j1x_x
sas_J1c ⇒ sas_2J1x_x
sinc ⇒ sas_sinx_x

For consistency:

Si ⇒ sas_Si

Change History (6)

comment:1 Changed 6 years ago by wojciech

  • Owner set to wojciech
  • Status changed from new to assigned

comment:2 Changed 6 years ago by richardh

I will be very happy with the new names, as proposed here, since they have the scalar constants indicated in them, and the "divide by x" part. This makes checking of code and documentation much easier and less prone to errors or misunderstandings.

I suppose that Si(x) is sufficiently well known as sin(x)/x to stay as sas_Si

comment:3 Changed 6 years ago by butler

  • Component changed from SasView to sasmodels
  • Priority changed from minor to major

comment:4 Changed 6 years ago by GitHub <noreply@…>

In daeef4c69f446781a24870a7e0182b629e74744d/sasmodels:

Merge pull request #24 from SasView?/ticket804


comment:5 Changed 6 years ago by wojciech

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:6 Changed 6 years ago by wojciech

In ca6cbc1cb491a7c62055c86b9919549b87b000bc/sasview:

Updated documentation for lib functions in sasmodels. Refers to ticket 804

Note: See TracTickets for help on using tickets.