Opened 5 years ago

Closed 5 years ago

#642 closed defect (fixed)

Loading Saved Fit or Saved Project Opens Multiple Plot and Fit Windows

Reported by: krzywon Owned by: krzywon
Priority: critical Milestone: SasView 4.0.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

When a saved fit or saved project is loaded, 2 plots and 6 fit windows are opened. I believe this has something to do with my Cansas reader changes.

Change History (2)

comment:1 Changed 5 years ago by krzywon

  • Priority changed from major to critical
  • Status changed from new to accepted

The Datainfo.run_name is being used as a unique id for each fitpanel, then the fitpanel is added to a dict in the format {run_name : fitpanel}. The problem is run_name is a dictionary, so checking if the fitpanel was drawn throws a TypeError? and is considered unsuccessful, even though it was actually drawn. One extra attempt to draw the data panel is made, but the fit is attempted 3 times.

The real question - why wasn't this an issue before? Is the added error handling finally catching the errors that were swallowed/ignored before?

I have a fix, but want to do more testing locally before committing.

comment:2 Changed 5 years ago by krzywon

  • Resolution set to fixed
  • Status changed from accepted to closed

The increased error handling seems to have done its job and caught errors that were likely being thrown before, but without being caught. I fixed P(r) and fit loading so they are not throwing Exceptions anymore.

Note: See TracTickets for help on using tickets.