Opened 4 years ago

Closed 4 years ago

#632 closed defect (invalid)

Batch fitting problem when switching to single fit and back

Reported by: ajj Owned by:
Priority: major Milestone: SasView 4.0.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

From Paul testing on 28th August:

"Batch fit - works pretty well only niggle is that if one loads a batch fit then switches to a single fit (to double check starting parameters for example) then comes back to the batch - the option for "chain fitting" is greyed out an not available and I could not make it come back."

Need to work out what the "correct" workflow/behaviour is here. May not have been an original use case.

Change History (3)

comment:1 Changed 4 years ago by piotr

Can't seem to be able to reproduce that

  • build 475 on windows 7
  • loaded 2 test files, sent to batch fitting (Fractal), Fit
  • Fitting /Chain Fitting: active
  • Selected FitPage1
  • Fitting /Chain Fitting: greyed out
  • Selected BatchPage1
  • Fitting /Chain Fitting: active

Which build did you test? I also looked at 468, which also works.

Last edited 4 years ago by piotr (previous) (diff)

comment:2 Changed 4 years ago by butler

Will test — was using ESS Windows build 466 which was the candidate release at the time. We then added two fixes before making the actual beta. Will check again on my machine with 466, 468 and most recent. If it is now fixed I will close otherwise will updated this ticket again.

comment:3 Changed 4 years ago by butler

  • Resolution set to invalid
  • Status changed from new to closed

Have done some extensive testing now with 466, 468 and 477 windows builds (Aug 25, Aug 30 and Sep 2, 2016 ESS builds) and have not been able to reproduce the problem mentioned. However, there is some small problem with the logic that allows the "chain fitting" to be active on a fit page until the batch fit tab is brought in focus then back to the fit tab at which point it is almost always greyed out again.

While this points to some convoluted logic in the GUI that could lead to more serious issues and should be cleaned up, I was unable to find anything more serious. Am thus closing this ticket and opening a new one for a future release

Note: See TracTickets for help on using tickets.