Opened 5 years ago

Closed 5 years ago

#628 closed defect (fixed)

Error when using core_multi_shell model

Reported by: lewis Owned by:
Priority: minor Milestone:
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

When attempting to fit data using the core_multi_shell model, the following error message occurs (for n=1):

Error(s) Occurred:
	Traceback (most recent call last):
  File "/vagrant/sasview/src/sas/sasgui/perspectives/fitting/fit_thread.py", line 82, in compute
    result = map(map_apply, inputs)
  File "/vagrant/sasview/src/sas/sasgui/perspectives/fitting/fit_thread.py", line 14, in map_apply
    return apply(arguments[0], arguments[1:])
  File "/vagrant/sasview/src/sas/sasgui/perspectives/fitting/fit_thread.py", line 11, in map_getattr
    return  getattr(classInstance, classFunc)(*args)
  File "/vagrant/sasview/src/sas/sascalc/fit/BumpsFitting.py", line 261, in fit
    if M.get_to_fit()]
  File "/vagrant/sasview/src/sas/sascalc/fit/BumpsFitting.py", line 123, in __init__
    self._define_pars()
  File "/vagrant/sasview/src/sas/sascalc/fit/BumpsFitting.py", line 139, in _define_pars
    value = self.model.getParam(k)
  File "/vagrant/sasmodels/sasmodels/sasview_model.py", line 438, in getParam
    raise ValueError("Model does not contain parameter %s" % name)
ValueError: Model does not contain parameter thickness2.npts
 
 None 


Further information might be available in the Console log (bottom right corner).

I've noticed the error only occurs if you don't click the "Compute" button before clicking "Fit".

The error occurs for all values of n, apart from n=0, and always seems to be "Model does not contain parameter thickness(n+1).npts"

Change History (3)

comment:1 Changed 5 years ago by butler

Testing on my windows 10 machine This seems to be a problem with the spherical variable layer modles (onion, sphericalsld, and multicoreshell). It does NOT seem to be a general problem with variable parameter infrastructure since RPA seems to not through the error. I do note that I get the same error even on 0 layers though I never tried starting with 0 layers immediately on loading SasView.

comment:2 Changed 5 years ago by butler

Also note that on windows 10 at least each time a new model is chosen the screen 'freezes' for an inordinate amount of time — suspect this is linked to how new models are now loaded?

comment:3 Changed 5 years ago by pkienzle

  • Resolution set to fixed
  • Status changed from new to closed

Now works when starting from sasview/run.py on Mac. Should work on all platforms, even in frozen versions, so closing as fixed. Reopen if it still fails.

Note: See TracTickets for help on using tickets.