Opened 2 years ago

Closed 2 years ago

#624 closed defect (fixed)

custom models reloaded too often

Reported by: pkienzle Owned by: wojciech
Priority: critical Milestone: SasView 4.1.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

Every custom model is being reloaded each time any model is updated.

To see this, uncomment line 117 of sasview_model.py (in load_custom_model), then use the model editor.

This is a minor performance issue, leading to lots of bloat in the plugins.log file if there are any errors in the models.

Change History (6)

comment:1 Changed 2 years ago by pkienzle

  • Milestone changed from SasView Next Release +1 to SasView 4.1.0
  • Priority changed from minor to critical

On mac release 4.0b1, multiple graphs are created on load which don't respond to close.

comment:2 Changed 2 years ago by pkienzle

Extra graphs are also loaded in Windows, but at least there they can be closed so it is merely annoying.

comment:3 Changed 2 years ago by wojciech

  • Owner set to wojciech
  • Status changed from new to assigned

comment:4 Changed 2 years ago by wojciech

This issue might be fixed in full 4.0 version.
I cannot reproduce multiple graphs problem and it seems that custom models are loaded only once.

comment:5 Changed 2 years ago by wojciech

In 47f2b5d45af5a67c5de39b0539edcbfbe5acbe7c/sasview:

Skipping extra Iq evaluation by not calling draw_model function from set polydisperisty parameters routine, ref #624 and #576

comment:6 Changed 2 years ago by wojciech

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.