Opened 4 years ago

Closed 2 years ago

#601 closed defect (fixed)

Loader Inconsistency in unit labels

Reported by: butler Owned by:
Priority: minor Milestone: SasView 5.0.0
Component: SasView Keywords:
Cc: Work Package: SasView GUI Enhancements

Description (last modified by butler)

some loaders give units in latex ([A-1] … ) while others give it in straight text 1/A. DataInfo displays text directly using texctrl box but same value is passed to the xaxis ans yaxis labels of the matplotlib graphs which really works better as LaTex. Should be consistant, preferably in a way that works well for both DataInfo display and the graph display

Change History (5)

comment:1 Changed 4 years ago by butler

  • Description modified (diff)

comment:2 Changed 4 years ago by butler

  • Milestone changed from SasView 4.0.0 to SasView 4.1.0

comment:3 Changed 4 years ago by butler

  • Milestone changed from SasView 4.1.0 to sasmodels Next Release +1

Didn't get address at SNS code camp so moving to next release+1 so as not to impede release of 4.1 in December

comment:4 Changed 3 years ago by butler

  • Milestone changed from sasmodels Next Release +1 to SasView 5.0.0

Really the loader should read and store the units in the data object in a way that is consistent but independent of the GUI (i.e. how it gets displayed in data info or the plot)

comment:5 Changed 2 years ago by LauraamForster

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.