#531 closed defect (invalid)

What's going on with fit threads?

Reported by: piotr Owned by:
Priority: major Milestone: SasView 4.0.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

They are all fine until it comes to communicating with them, e.g. stopping them.
The standard mechanism is to set a control variable, pollable by the thread.
This is done here but the polling doesn't seem to happen or to be acted on.

I would like some time to investigate this.

Change History (4)

comment:1 Changed 20 months ago by piotr

Paul K to the rescue. This is working as expected - choose the right optimizer and you see things work properly.
The "proper" behaviour of threads being actively killed will happen when we switch to Qt.

Therefore - not a bug.

comment:2 Changed 20 months ago by piotr

  • Resolution set to invalid
  • Status changed from new to closed

comment:3 Changed 20 months ago by piotr

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:4 Changed 20 months ago by piotr

  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.