Opened 6 years ago

Closed 6 years ago

#430 closed defect (fixed)

Mac documentation window broken again

Reported by: butler Owned by: butler
Priority: blocker Milestone: SasView 3.1.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

After the updates that added a number of help buttons and fixed the DocumentationWindow class so that help buttons could access into a file to an appropriate anchor, the Mac documentation window pulls up the file called but the css does not seem to be applied nor are any of the links active.

Change History (3)

comment:1 Changed 6 years ago by butler

  • Owner set to butler
  • Status changed from new to accepted

comment:2 Changed 6 years ago by butler

It seems the problem is that the PC path is C:\xxxx while the mac Path is /Application/xxxx. Thus the url for the pc MUST include 3 slashes (as file:///WindowsPath) whereas the Mac only need two since the third comes from the start of the mac path (as file://MacPath). The current solution that seems to work is to use three. The mac seems to be OK with four as long as all of them are raw and not encoded (as %2F) The current problem was that "file:///%2F" was able to load the file but very bizarely then put the path of that file as root so that no links worked. Preventing the / from being encoded seems to work for now. If that changes in the future we may need to use an "if mac do xxx" approach which I find a bit ugly.

comment:3 Changed 6 years ago by butler

  • Resolution set to fixed
  • Status changed from accepted to closed

This seems to be fixed for now.

Note: See TracTickets for help on using tickets.