Opened 3 years ago

Closed 20 months ago

#410 closed defect (fixed)

error with raspberry model

Reported by: butler Owned by: ajj
Priority: major Milestone: SasView 4.0.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

Lilo Pozzo reports the following problem:

I tried fitting gold nanoparticle decorated emulsions using both Igor and SASView. When I placed these parameters (experimental) on to the raspberry model that appears in the IGOR macros (I think it is raspberryV40), the intensity would go negative as shown.

I could not figure out the problem because the new procedures raspberryV40 were hard to interpret (for me). This is the plot I get when fitting using the raspberryV40 and then compared to the raspberry (original model written by Andrew).

Parameters
vf Large        0.0021
Radius Large (A)        500
SLD Large sphere (A-2)  1.3e-05
vf Small        1.14e-05
Radius Small (A)        57
fraction Small at surface       0.4
SLD Small sphere (A-2)  0.000123
delta   0
SLD solvent (A-2)       9e-06
bkgd (cm-1)     0

Also, I believe the error (if there is one) may have been moved also to SASView since that function also goes negative when I try the same parameters.

Attached are the plots she refers too.

Attachments (3)

PastedGraphic-1.pdf (24.9 KB) - added by butler 3 years ago.
PastedGraphic-2.pdf (20.3 KB) - added by butler 3 years ago.
PastedGraphic-3.tiff (46.1 KB) - added by butler 3 years ago.

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by butler

Changed 3 years ago by butler

Changed 3 years ago by butler

comment:1 Changed 2 years ago by butler

Updated by Lilo Pozzo April 26, 2015

I think I figured out the problem with the model. It was, at some point, modified to fit directly using the fractional surface area covered. This is a more useful parameter to extract. However, it makes the function highly unstable because there are not necessarily enough small particles to fill the surface at any given surface density. I no longer think there is an error in the equations but the fits tend to go crazy in the solvers. The original equations, used in an older igor version, would fit instead to the fraction of total small particles that would adsorb. This is a well-defined parameter between 0-1. It is also independent of all other parameters. In contrast, the fraction area covered is interrelated with the large particle size (how much area is available) and the volume fractions of both large and small particles. There are unstable regions that are really hard to eliminate with constraints and the solver goes crazy.

My question is this. Is there any way we can use or run the old (original) raspberry? I think it is currently of very little use in the current configuration because of the above reasons.

comment:2 Changed 2 years ago by ajj

  • Milestone changed from SasView Next Release +1 to SasView 4.0.0
  • Owner set to ajj
  • Status changed from new to assigned

I sent the old IGOR version of the model to Lilo, so I think from that perspective the problem is dealt with.

If the version parameterised by surface fraction coverage is proving to be unstable, we should remove it. So need to replace the version in SasView with that version and update the documentation. I will do this when I transfer the model to sasmodels.

Last edited 21 months ago by butler (previous) (diff)

comment:3 Changed 21 months ago by butler

  • Priority changed from major to blocker

From the last entry his should be a core sasmodels task? … though question whether both parameterizations could be included with appropriate explanations in the documentation? Either way moving to blocker for now as core task.

comment:4 Changed 20 months ago by butler

  • Priority changed from blocker to major

comment:5 Changed 20 months ago by ajj

  • Resolution set to fixed
  • Status changed from assigned to closed

Reverted the model to be exact match to math in paper. Thus it is now using the fraction of small spheres adsorbed, rather than trying to use surface coverage. Seems the surface coverage version had issues due to the circular relation of some values.

Note: See TracTickets for help on using tickets.