Opened 4 years ago

Closed 4 years ago

#390 closed defect (fixed)

Problem with menu and toolbar on mac

Reported by: butler Owned by: ajj
Priority: blocker Milestone: SasView 3.1.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

Two issues identified on the mac:

  1. The menu bar on the mac starts up wiht TWO Fitting items. Fitting is the one menu item which behaves differently from the others in that it belongs to the perspective. So when switching to P(r) for example that menu item disappears and would be replaced by a P(r) menu item except that neither P(r) nor Invariant define a menu item. Somehow the mac is confused and has one fitting menu which is permanent and one which disappears as it is meant to. Not that since the optimization engine choice show up on the fitting menu and are used presumably by P(r) at least? this is a problem — will make separate ticket on that.
  2. the label box on the toolbar which is supposed to contain which perspective is active is blank. Note that that is probably redundant and could be removed since the application frame title seems to show the name of the active perspective both on the PC and the mac

Change History (7)

comment:1 Changed 4 years ago by pkienzle

The drop down box Tool:Data Operation:Data1 doesn't work on mac, but works on windows.

comment:2 Changed 4 years ago by butler

the Data Operation problem is a known issue and is a problem on both mac and PC and is part of ticket #370. Am adding this mac comment to that ticket. Will not address here

comment:3 Changed 4 years ago by butler

  • Milestone changed from SasView Next Release +1 to SasView 3.1
  • Priority changed from major to blocker

Andrew Jackson created a new ticket #403 which is really a duplicate of this one. Am copying his comments here before closing that ticket. Also significantly raising priority to match his call on it.

On the Mac (OS X 10.10) two fitting menus appear. This might seem to just be cosmetic, but the menus do not confer the same functionality - for instance the Constrained/Simultaneous? Fit option only becomes un-greyed in the "first" menu and not in the second.
In any case, this is very confusing for the user.

comment:4 Changed 4 years ago by butler

Did not notice the added comment by AJJ on ticket #403 which I now copy here:

NB tested on build #143 from april 2nd

comment:5 Changed 4 years ago by butler

  • Owner set to ajj
  • Status changed from new to assigned

comment:6 Changed 4 years ago by mathieu

There are apparently two mechanisms to set the default perspective at startup. One was using the "standalone" data member of base_plugin, and the other was through the SasView? configuration. The two were clashing. Standalone=True was hard-coded for the fitting perspective. I remove that so that it behaves like a normal perspective.

comment:7 Changed 4 years ago by ajj

  • Resolution set to fixed
  • Status changed from assigned to closed

This looks like it is fixed on Mac and Windows. Declaring it fixed.

Note: See TracTickets for help on using tickets.