Opened 7 years ago

Closed 7 years ago

#381 closed defect (fixed)

PrView now broken

Reported by: butler Owned by: mathieu
Priority: blocker Milestone: SasView 3.1.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description (last modified by butler)

In all the cleanup PrView which worked relatively well in version 3.1 alpha just before code camp, is now very broken:

Discovered as I was trying to add the Help button to this panel (have this and Invariant left to finish documentation redesign). Have decided not to confuse the issue by adding that now and would like to see this fixed first.

Used test data 1000A_sphere_dsm.xml for most all of my testing (NOTE: the DMAX is very large on this .. and in fact the name is WRONG it is 1000nm!!). Main issues

  1. Buttons do not update value (regularization constant and number of terms). It does seem to take the number typed in manually. Error reported in sasview log is:
    2015-03-22 10:57:56,072 ERROR InversionControl._on_accept_alpha: String or Unicode type required
    2015-03-22 10:58:40,540 ERROR InversionControl._on_accept_nterms: String or Unicode type required
    
  2. The number of terms is NOT being evaluated. Suggested value is always the defaule of 10. Error reported in console is given below. In the alpha release, once I put in a Dmax of 20,000 (2 microns diameter) it suggests 25 and clicking on the button properly puts that value into the parameter box.
    	Could not estimate number of terms
    
  1. The "explore box" is broken in windows but not on mac it seems.
    1. You can put some numbers in but quickly some boxes become inaccessible such as "number of points" and may even get stuck in max or min and not allow chaning any other value … including the drop down.
    2. The alpha version on PC behaves very well and even deals elegantly with putting a SMALLER number in the max by simply inverting the plot scale.

Change History (7)

comment:1 Changed 7 years ago by butler

  • Priority changed from major to blocker

comment:2 Changed 7 years ago by butler

  • Description modified (diff)

comment:3 Changed 7 years ago by butler

  • Description modified (diff)

comment:4 Changed 7 years ago by mathieu

  • Owner set to mathieu
  • Status changed from new to accepted

comment:5 Changed 7 years ago by mathieu

  • Owner changed from mathieu to butler
  • Status changed from accepted to assigned

This should now be fixed. I believe item 3 was caused by item 1. It now works on OSX. Someone should test on Windows.

Last edited 7 years ago by mathieu (previous) (diff)

comment:6 Changed 7 years ago by butler

  • Owner changed from butler to mathieu

Nope …still broken. Now in fact clicking on "explore" fails altogether (no panel pops up). the traceback yields

Traceback (most recent call last):
  File "C:\Users\Paul\git\sasview\src\sas\perspectives\pr\inversion_panel.py", line 893, in _on_explore
    dialog = ExploreDialog(pr, 10, None, -1, "")
  File "C:\Users\Paul\git\sasview\src\sas\perspectives\pr\explore_dialog.py", line 182, in __init__
    self.__do_layout()
  File "C:\Users\Paul\git\sasview\src\sas\perspectives\pr\explore_dialog.py", line 336, in __do_layout
    self.output_box.SetEditable(False)
  File "C:\Users\Paul\workspace\SasView\Python27\lib\site-packages\wx-3.0-msw\wx\_core.py", line 13334, in SetEditable
    return _core_.TextEntryBase_SetEditable(*args, **kwargs)
wx._core.PyAssertionError: C++ assertion "!HasFlag(wxCB_READONLY)" failed at ..\..\src\msw\combobox.cpp(421) in wxComboBox::GetEditHWND(): read-only combobox doesn't have any edit control

Note that this is on my development machine only as the Jenkins site is down so official builds are not being built.

comment:7 Changed 7 years ago by mathieu

  • Resolution set to fixed
  • Status changed from assigned to closed

I'm closing this ticket and moving the part that was unrelated to the cleanup effort to a new ticket.
The item three above appears to be related to the move to wx 3.0. It has been moved to #397.

Note: See TracTickets for help on using tickets.