Opened 7 years ago

Closed 7 years ago

Last modified 2 years ago

#38 closed defect (fixed)

Detail button on custom model gives erroneous error message

Reported by: butlerpd Owned by: jhjcho
Priority: major Milestone:
Component: SansView Keywords:
Cc: Work Package:

Description

The "detail" button on the fit page normally calls up the help file at the appropriate place for the model chosen in the drop down box. However, as there can be no entry in that help file for custom models, the button instead pops up whatever the user entered in the "description" field.

However, at the same time it produces an error message in the info line at the very bottom which reads:
Model does not contains an available description Please try searching in the Help window

Aside from the contradictory information being given, this is a case where, even in the event there is no entry to pop up, the behavior should be to pop up a box anyway (that is where the user is looking/expecting to see something) with the information that "sorry, no information is available for this model" — suggesting to go search through the documentation is also probably not appropriate.

Note also that the information line is persistent. That means that if I click details when there are none, I get an error which will still be there when I then click on details for a model that does have information.

Change History (3)

comment:1 Changed 7 years ago by jhjcho

  • Owner set to jhjcho
  • Status changed from new to assigned

comment:2 Changed 7 years ago by jhjcho

  • Status changed from assigned to accepted

comment:3 Changed 7 years ago by jhjcho

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.