Opened 7 years ago

Closed 7 years ago

Last modified 3 years ago

#36 closed enhancement (fixed)

Hide/Delete graph is counter-intuitive

Reported by: butlerpd Owned by: robert-whitley
Priority: critical Milestone:
Component: SansView Keywords:
Cc: Work Package:

Description

Currently the x on the top left of the graph behaves as a hide rather than the expected kill/delete. The X in the graph menu in fact kills. There are several solutions such as making the top x kill as expected and replacing the X icon with something more akin to a hide (and appropriate tool tip). Another would be to remove the icon and add a - for hide at the top of the graph next to the x, again giving each the expected behavior, etc. as it is it is extremely confusing

Change History (8)

comment:1 Changed 7 years ago by robert-whitley

  • Owner set to robert-whitley
  • Status changed from new to accepted

comment:2 Changed 7 years ago by robert-whitley

  • Owner robert-whitley deleted
  • Status changed from accepted to assigned

comment:3 Changed 7 years ago by robert-whitley

  • Owner set to robert-whitley
  • Status changed from assigned to accepted

Look into using wx.lib.agw.aui

comment:4 Changed 7 years ago by butlerpd

Jae-Hie points out, if I understand it, that if wx.lib.agw.aui does not cut it, to achieve this in the current framework would require:

1) create a custom icon -
2) make a button out of it and place that appropriately
3) write custom code to hide
4) attach that code to the event generated by clicking the custom button

comment:5 Changed 7 years ago by robert-whitley

The http://xoomer.virgilio.it/infinity77/AGW_Docs/index.html|documentation can't be viewed at work due to potential spyware.

comment:6 Changed 7 years ago by robert-whitley

Add hide button and change x button so that it deletes the plot.

https://builds.sns.gov/view/SansView/job/sansview_snowleopard_32bit/219/

comment:7 Changed 7 years ago by robert-whitley

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:8 Changed 7 years ago by robert-whitley

Changed Icon because of feedback in meeting said it should be a closed eye.

Note: See TracTickets for help on using tickets.