Opened 5 years ago

Closed 21 months ago

#260 closed defect (fixed)

Box integration does not update when entering values in dialog

Reported by: ajj Owned by:
Priority: major Milestone: SasView 4.2.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

If you change the parameters of a box integration from the dialog box, the results don't update i.e. the calculation is not performed when values are manually entered.

Dragging the handles on the plot does update the values.

Change History (5)

comment:1 Changed 5 years ago by butler

Actually, on the PC at least, as with many wx boxes you must hit enter for the new value to be accepted. This should be added as a known issue I gues? Testing seems to work on my PC. HOWEVER — two other things pop up. First using the section slicer I was able to freeze the graph once…. but not able to reproduce. This suggests there is a small bug somewhere and the code should get a close look.

Annoyingly the handles can disappear if the typed in parameters put them outside the graph making it difficult to manualy grab (can be fixed by going back to the manual edits and changing the size to bring the handles back into range)

comment:2 Changed 5 years ago by ajj

  • Work Package set to SasView Bug Fixing

comment:3 Changed 4 years ago by krzywon

The calculation only updates when updating the box from the plot window but not from the boxsum inputs. When trying to make the updates a two way street, the result is an infinite event loop where the plot window updates the boxsum window and then the boxsum window updates the plot window, and so on and so forth.

What this means is we can modify the boxsum window values, but that does nothing to update the calculated values. I'm going to create a check for changed values, but this probably isn't going to be done today like I had hoped.

comment:4 Changed 2 years ago by piotr

This has been properly implemented in the qt version.

comment:5 Changed 21 months ago by butler

  • Milestone changed from SasView Next Release +1 to SasView 4.2.0
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.