Opened 4 years ago

Closed 8 months ago

#230 closed enhancement (fixed)

Default "load data" directory to the last one used

Reported by: ajj Owned by:
Priority: minor Milestone: SasView Next Release +1
Component: SasView Keywords:
Cc: Work Package: SasView GUI Enhancements

Description


Change History (9)

comment:1 Changed 4 years ago by butler

  • Milestone changed from SasView 3.0.0 to SasView Next Release +1

This is supposed to work and code looks like it should work but it doesn't always do so.

comment:2 Changed 3 years ago by ajj

  • Work Package set to SasView Bug Fixing

comment:3 Changed 3 years ago by butler

  • Milestone changed from SasView Next Release +1 to SasView 3.1

comment:4 Changed 3 years ago by butler

  • Milestone changed from SasView 3.1 to SasView Next Release +1

We need to agree on what we want as the new interface for this. Probably a real preferences window that lets one enter values for the items set in the configuration file (at least those we will allow the user to change). That however will be a major undertaking so probably not for this release. Hence moving from 3.1 to next + 1

comment:5 Changed 3 years ago by butler

  • Type changed from defect to enhancement
  • Work Package changed from SasView Bug Fixing to SasView GUI Enhancements

comment:6 Changed 8 months ago by ajj

This seems to be working? Is it fixed?

comment:7 Changed 8 months ago by krzywon

I tested v4.1.0 release using Win10 and I agree with Andrew, this looks like it's working.

comment:8 Changed 8 months ago by butler

Would be very happy to get a consensus and close this but absolutely nothing has changed since the ticket was first written. The problem is one of choosing the expected behavior. currently (as it has for a long time) the last directory from which a file was loaded is the default directory for the next load. However, it does not persist from session to session unless the new default directory is saved by clicking View →Startup Settings and choosing "current View"

If it should persist without that then we should change that menu and also the behavior. I am all in favor of that but since the ticket was raised by someone else….

Ultimately (mainly in new GUI?) we should probably replace that clunky mechanism with a proper setting page.

comment:9 Changed 8 months ago by ajj

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.