Opened 4 years ago

Closed 9 months ago

#219 closed task (obsolete)

easy developer setup

Reported by: butler Owned by: Parker
Priority: critical Milestone: Admin Tasks
Component: SasView Keywords:
Cc: Work Package: SasView Admin

Description

Create a downloadable package with simple set of instructions that will allow a new developer from relatively unsophisticated to professional can quickly get up and running. Should include both getting going without any IDE (from command line) and with Eclipse IDE.

Change History (9)

comment:1 Changed 4 years ago by Tobias Richter

I've committed a .project file in the top level that allows easy importing of sasview into eclipse when starting with a checked out copy.

comment:2 Changed 4 years ago by Tobias Richter

I've also added a README.TXT to the docs/ folder with some initial hints for building and pointer to the website/wiki.

comment:3 Changed 4 years ago by Tobias Richter

Converted the PDF outlining Eclipse operations linked from Development? to Wiki content on that page.

comment:4 Changed 3 years ago by Peter Parker

  • Work Package set to SasView GUI Redesign

I had to set up my development environment again yesterday and took the opportunity to look into Anaconda again. Anaconda is a distribution of Python than comes bundled with a lot of 3rd party modules, including a lot of the dependencies of SasView?.

An absolutely excellent feature of Anaconda is "Conda", it's package manager. Through this, users have the ability to install modules in a very straightforward and easy manner. It also allows for the creation of separate "environments" (similar to virtualenv).

Combining this with Binstar (which allows for the creation of Conda package repositories), I think what we have now are all the tools needed to deliver a development environment in Windows (as well as, in theory, all the other platforms) that is completely separate from whatever installation of Python you might currently have, all via the execution of a single shell script.

Here is a link to my Binstar repository, which for testing purposes I've filled with Conda packages that do not come with Anaconda by default, or which at the time of writing are not available via a straightforward conda install module command:

https://binstar.org/PeterParker

I envision all our dependencies being hosted on a shared SasView? account, so that we can centrally manage dependencies for everyone.

comment:5 Changed 3 years ago by Peter Parker

  • Work Package changed from SasView GUI Redesign to SasView Admin

comment:6 Changed 3 years ago by Peter Parker

A nice summary of the need for Conda:

http://www.continuum.io/blog/conda

comment:7 Changed 3 years ago by butler

  • Priority changed from major to critical

comment:8 Changed 3 years ago by Peter Parker

Progress report:

  • The "Easy" Developer Set Up Guide is practically complete. I've been adding solutions for known issues (i.e. previous installations of python, etc.) as and when we come across them. Consider it an evolving document!
  • Binstar has Windows modules only. No Mac / Linux.

Next steps:

  • Paul K quite rightly pointed out that it would be good if we had the .yaml recipes for the binstar-hosted modules, effectively making sure that they are reproducible and we're able to modify or upgrade the modules.
  • Create Mac or Linux versions of the module.

comment:9 Changed 9 months ago by butler

  • Resolution set to obsolete
  • Status changed from new to closed

This was never followed up. Have created a new ticket #873 based on renewed interest in lowering the barrier for new developers but much has changed since this ticket was being worked on. Still some of the comments could be useful so have provided a link to this ticket from the other. Am now closing this

Note: See TracTickets for help on using tickets.