Opened 6 years ago

Closed 3 years ago

#205 closed enhancement (fixed)

Provide for Kratky representation of data

Reported by: smk78 Owned by: ajj
Priority: critical Milestone: SasView 4.0.0
Component: SasView Keywords: Graph, Kratky, Invariant
Cc: Work Package: SasView GUI Enhancements

Description (last modified by butler)

Modify Graph → Change Scale → Properties dialog, and provide
underlying code to allow a Kratky representation (Q2.I(Q) vs Q) of
the data.

Whilst of general use, this is particularly useful for establishing
if the data is suitable for Invariant integration; ie, if the integral
is open or closed.

Change History (12)

comment:1 Changed 6 years ago by smk78

Oops, sorry about the wiki formatting! That should say (Q-squared.I(Q)) vs Q.

comment:2 Changed 5 years ago by butler

  • Owner set to ajj
  • Status changed from new to assigned

comment:3 Changed 5 years ago by smk78

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:4 Changed 3 years ago by butler

  • Description modified (diff)
  • Milestone changed from SasView 3.0.0 to SasView 4.0.0
  • Priority changed from minor to critical
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Work Package set to SasView GUI Enhancements

Am reopening this ticket as it is not working at the moment. A kratky option is provided but no q2I(q) option for the y axis and PlotPanel.py does not know about this view so is ignored (worse it raises a traceback error). It needs to be added in PropertyDialog.py and PlotPanel.py. It may also need to be added to transform. Finally, it would be good to be able to plot reduced Kratky (qRg rather than q) but this can wait. For release 4.0 we either need to fix the basic Kratky or remove it as an option. Since it did not work before either (checked 3.1.2) that should be fine as well (though not ideal of course)

Last edited 3 years ago by butler (previous) (diff)

comment:5 Changed 3 years ago by paul butler <butlerpd@…>

In [3409a909ae6ba9a55295c5a75fa539468268c2ec]:

references #205 - Removed Kratky plot choice from linearized plots for
now since it doesn't currently work.

comment:6 Changed 3 years ago by Piotr Rozyczko <piotr.rozyczko@…

In [e3ae090acafb0a35e27298bc8dd1e99d1ffab206]:

Merge master

see issue #590. fix error in q.rg and uncertainties in Rg and I0.
Uncertainty calculation for slope and intercept are still wrong I
believe.

references #205 - Removed Kratky plot choice from linearized plots for
now since it doesn't currently work.

close #590. A lot of problems were caused by LineModel? and LinerFit?
having different equations (ax+b vs a+bx). Further errors in
calculations, particularly of uncertainties were fixed. The fact that
the fits to not account for smearing was verified and a warning added.
Code was also modified to update the qmin and qmax to match changes in
the transformed xmin xmax. Lots of documentation was added and the
fitdialog layout was cleaned up considerably. This is now usable though
the design of the user interface (and the whole design of linear fits)
could use a rethink.

comment:7 Changed 3 years ago by Lewis O'Driscoll <lewis.o'drisco

In [09d6719cfd292cf93eba82c2e03a3fbbb8c5486c]:

Add Kratky option to plot scale. Closes #205

comment:8 Changed 3 years ago by smk78

In 8abd96d6ebdf20551265a5a33a9fd0d56ebe5584 Lewis says:

Fixing the error bar calculations also removes the need to scale the y axis when changing to a Porod or Kratky plot, so commit f2f6af9 has effectively been reverted.

comment:9 Changed 3 years ago by smk78

In b2f21e0d2280f5fd1cbb854d2c045b937ca32f94 Lewis says:

Fix LaTeX formating of labels when scale changed

comment:10 Changed 3 years ago by smk78

In 51296869a9635f6bbe7ea2bf9ea57b2f5ee095cf Lewis says:

Make PropertyDialog ComboBoxes read-only.

Also set scale values automatically when the user chooses a view, making
some of the logic in PlotPanel redundant

comment:11 Changed 3 years ago by smk78

In 1ed6be74dd086a570674b6acb2a8d3c7fa0bf36d Lewis says:

Fix units on Kratky plot

comment:12 Changed 3 years ago by smk78

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.