Opened 5 years ago

Closed 5 years ago

#191 closed defect (fixed)

Data Info broken

Reported by: butler Owned by: krzywon
Priority: major Milestone: SasView 3.0.0
Component: SasView Keywords:
Cc: Work Package:

Description

Right clicking on the data name in the data manager panel brings up the option to look at Data Info. This used to bring up a box with the data and its header information. In Build 1 of 3.0.0 developer version on Windows 7 at least this no longer works. This probably gets fixed with Jeff's reader changes but should be checked

Change History (2)

comment:1 Changed 5 years ago by krzywon

  • Owner set to krzywon
  • Status changed from new to accepted

The datainfo screen is loaded by guiframe, using info taken from data_info. The issue is with the data coming from data_info, specifically the dx/dxw/dxl arrays. When processing the data, guiframe expects dxw and dxl to be None when no data is present. If an empty array is passed, the class attempts to pull data from it, throwing an exception and ending the process, so the window does not appear. For the new cansas reader, I have set it up so the empty arrays are set to None, to fix this issue. For the long term, guiframe should check to the array length is greater than the iteration number. I am working on this fix and should have it out shortly.

comment:2 Changed 5 years ago by krzywon

  • Resolution set to fixed
  • Status changed from accepted to closed

This is fixed now.

Note: See TracTickets for help on using tickets.