Opened 5 years ago

Closed 2 years ago

Last modified 2 years ago

#186 closed defect (fixed)

Data Operation Tool does not scale a dataset

Reported by: smk78 Owned by: lewis
Priority: minor Milestone: SasView 4.0.0
Component: SasView Keywords:
Cc: Work Package: SasView GUI Redesign

Description

The Data Operation Tool allows for a dataset to be multipled by a number, the default multiplier being 1.0.

However, whilst changing this multiplier and clicking apply generates a new SasView? dataset, either no multiplier is applied, or the value applied is just 1.0.

Reported by Arnauld Poulesquen, 14/05/2013.

Change History (7)

comment:1 Changed 5 years ago by butler

  • Milestone set to WishList
  • Priority changed from critical to minor

Upon further investigation the problem is that currently the user must hit enter after entering a number before applying. Just clicking in a different box won't do it. Clearly want a better updating mechanism, but the functionality does work so downgrading the urgency. The number being multiplied is shown in the big box (where data shows up if adding a data set rather than a number) and is the exact number that will be applied.

Clearly the whole interface and logic was designed with two data sets in mind and the scaler option added later by user demand. Would be nice to make the usage more transparent

comment:2 Changed 4 years ago by ajj

  • Work Package set to SasView Bug Fixing

comment:3 Changed 4 years ago by butler

  • Work Package changed from SasView Bug Fixing to SasView GUI Redesign

comment:4 Changed 2 years ago by lewis

  • Owner set to lewis
  • Status changed from new to assigned

comment:5 Changed 2 years ago by Lewis O'Driscoll <lewis.o'drisco

In [0e760e9190d1a156409589ee9c50372130d80dbe]:

Update GUI on TEXT_EVT instead of TEXT_EVT_ENTER (closes #186)

comment:6 Changed 2 years ago by lewis

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:7 Changed 2 years ago by butler

  • Milestone changed from WishList to SasView 4.0.0
Note: See TracTickets for help on using tickets.