Opened 4 years ago

Closed 4 years ago

#1064 closed defect (fixed)

"Fitting did not converge!!!" error with a Sum|Multi plugin model

Reported by: smk78 Owned by:
Priority: critical Milestone: SasView 4.2.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

Reported by User alessandra.delgiudice@…:

Dear SASview developer,

I found problems making fits with Sum|Multi plugin models in the 4.1.2 version. In brief:

In the 4.1.2 version I got a "Fitting did not converge!!!" error, whereas trying with the 4.1 version (installed on the same pc in a different folder) the fit worked.

I did a test with simulated data:

I created a Sum|Multi model with the dedicated tool: sphere_plus_hollowcylinder.py

I saved a calculated curve with parameters:
p1_scale 0.5
p1_background 0
p1_sld 9.45
p1_sld_solvent 9.4
p1_radius 100
p2_scale 0.5
p2_background 0
p2_radius 50
p2_thickness 20
p2_length 1000
p2_sld 9.45
p2_sld_solvent 9.4
scale_factor 1

and 1400 points as sphere_and_hollow_cylinder_out.txt

I loaded this file as a data file to be fitted. I changed the sphere radius value from 100 to 50, and then clicked to "Fit". Nothing happened and I got a "Fitting did not converge!!!" error in the console.

I had an older installation file for SASview 4.1 and I installed it on my laptop in the folder SasView_4_1 instead of SasView (where the 4.1.2 version is)

The same test worked in this case.

When trying a similar test with a simpler model (sphere with default parameters), the fit starting from a different value of the sphere radius (100 instead of 50) worked with the 4.1.2 version.

I attach the sasview log as sasview_20180112.log. What I described starts with the line "2018-01-12 11:50:05,181 INFO —- SasView session started —-"

Attachments (2)

sasview_20180112.log (49.7 KB) - added by smk78 4 years ago.
Alessandras log file
ticket1064fixed.png (152.4 KB) - added by smk78 4 years ago.
Screenshot of SasView? Master pulled 13/02/2018 10:30GMT

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by smk78

Alessandras log file

comment:1 Changed 4 years ago by smk78

Alessandras PC was Windows 10 Home on a Dell XPS 9360 with processor Intel® Core™ i7-7500U CPU @ 2.70GHz, 2901 Mhz, 2 cores, 4 processors.

I am also using a W10 PC and managed to reproduce this behaviour.

comment:2 Changed 4 years ago by smk78

Wojtek has now reproduced this behaviour on a Mac using 4.1.2

comment:3 Changed 4 years ago by butler

What is the status of this ticket? Does the problem still exist in 4.2 (i.e. master build?) or can we close this as fixed in 4.2?

Changed 4 years ago by smk78

Screenshot of SasView? Master pulled 13/02/2018 10:30GMT

comment:4 Changed 4 years ago by smk78

Have just pulled from master, built locally (32 bit, tinycc=no64) on Win 7, and re-tried Alessandra's instructions. SasView fitted the model data it had just created. Screen shot attached. The problem seems to be fixed.

comment:5 Changed 4 years ago by smk78

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.