Opened 4 years ago

Closed 4 years ago

#1062 closed defect (worksforme)

win32 build not installing correctly

Reported by: butler Owned by: piotr
Priority: blocker Milestone: SasView 4.2.0
Component: SasView Keywords:
Cc: Work Package: SasView Bug Fixing

Description

Rob Dalgliesh reports that the Jan 19, 2018 build of SasView won't install. Instead the error message attached is presented. I reproduced this error downloading the win7 build from the master builds tab. This however is currently the 32 bit build. It attempts to install on the x86 program folder and then throws this error. If however I download the 64 bi win7 version (from the "ALL" builds tab … and not the PR win7 build). the system installs with no issues in program files.

Depending on the cause this may be moot if we do not release a 32 bit version but until we decide that I will label this blocker.

Attachments (1)

InstallError.png (12.2 KB) - added by butler 4 years ago.
installation error message

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by butler

installation error message

comment:1 Changed 4 years ago by piotr

  • Owner set to piotr
  • Status changed from new to accepted

comment:2 Changed 4 years ago by piotr

Let me understand it:

32-bit Sasview installer on Windows 64: works locally as expected on a number of hosts.
64-bit Sasview installer on Windows 64: works locally as expected on a number of hosts.

The attached image is from a windows 64 machine (see "c:\program files (x86)" which exists only on win64).
This means the 32 bit installer should work.

If you (Paul) managed to reproduce the problem, please let me know the installer build date, your OS specs and confirm the failure point.

comment:3 follow-up: Changed 4 years ago by richardh

Tried the 32 bit Win7 installer from Jenkins on my office PC, which is windows 7, all worked fine for me.

Tried install to 2 different directories, including one in Program Files x86.

Richard (who shares an office with Rob D who first reported this)

comment:4 in reply to: ↑ 3 Changed 4 years ago by gonzalezm

Replying to richardh:

Tried the 32 bit Win7 installer from Jenkins on my office PC, which is windows 7, all worked fine for me.

Tried install to 2 different directories, including one in Program Files x86.

Richard (who shares an office with Rob D who first reported this)

The 32-bit install worked also fine for me, on a Windows 8.1 PC.

comment:5 Changed 4 years ago by richardh

Following comments over weekend from Paul B who still sees failures, I checked again today on my desktop Win7 64 bit machine.
This time I uninstalled all mentions of (very old???) sasview in add/remove programs, and deleted program files (x86) \sasview directory.
From Jenkins the latest win7 32bit installer number 36 of 18 days ago, works fine for me, in the default install directory.

Richard

comment:6 Changed 4 years ago by butler

  • Resolution set to worksforme
  • Status changed from accepted to closed

While reported on Sunday Jan 28 the last test I did and reported failing was Jan 23 so using build from before that. Today, Sunday Feb 4 I have used the Feb 2 32 build on jenkins which now seems to install on all 3 machines I've tried (a windows 7 laptop, an old AMD 64bit running windows 10 Home edition and a virtual machine running windows server 2016 enterprise) … and all three install just fine. I have not tested my office windows 7 machine again but since these did not work before and everyone else now gets it to work am going to assume that whatever the glitch it has been magically fixed (assuming Rob D also has it working now since test by office mate Richard Heenan says all his tests now show it is working).

So going to close now

Note: See TracTickets for help on using tickets.