Changeset 2a8bd705 in sasview for sasview/sasview.spec


Ignore:
Timestamp:
Jul 25, 2017 4:36:48 AM (7 years ago)
Author:
Piotr Rozyczko <rozyczko@…>
Branches:
ESS_GUI, ESS_GUI_Docs, ESS_GUI_batch_fitting, ESS_GUI_bumps_abstraction, ESS_GUI_iss1116, ESS_GUI_iss879, ESS_GUI_iss959, ESS_GUI_opencl, ESS_GUI_ordering, ESS_GUI_sync_sascalc
Children:
b00414d
Parents:
6ff2eb3
Message:

Changes to allow pyinstaller builds

File:
1 edited

Legend:

Unmodified
Added
Removed
  • sasview/sasview.spec

    • Property mode changed from 100755 to 100644
    re42c8e9d r2a8bd705  
    5151datas.append(('welcome_panel.py','.')) 
    5252 
     53datas.append((os.path.join(PYTHON_LOC,'Lib','SocketServer.py'),'.')) 
     54 
    5355# TODO 
    5456# NEED BETTER WAY TO DEAL WITH THESE RELATIVE PATHS 
    5557datas.append((os.path.join('..','..','sasmodels','sasmodels'),'sasmodels')) 
    5658datas.append((os.path.join('..','src','sas','sasgui','perspectives','fitting','plugin_models'),'plugin_models')) 
    57  
    58 # precompile sas models into the sasview build path; doesn't matter too much 
    59 # where it is so long as it is a place that will get cleaned up afterwards. 
    60 import sasmodels.core 
    61 dll_path = 'compiled_models' 
    62 if not (os.path.exists(dll_path)): 
    63     os.mkdir(dll_path) 
    64 dll_path2 = os.path.join(dll_path, dll_path) 
    65 if not (os.path.exists(dll_path2)): 
    66     os.mkdir(dll_path2) 
    67  
    68 compiled_dlls = sasmodels.core.precompile_dlls(dll_path, dtype='double') 
    69  
    70 # include the compiled models as data; coordinate the target path for the 
    71 # data with installer_generator.py 
    72 datas.append((os.path.join('compiled_models','compiled_models'),'compiled_models')) 
    7359 
    7460# These depend on whether we have MKL or Atlas numpy 
     
    114100# Spelled out to enable easier editing 
    115101excludes = [] 
    116 excludes.append('libzmq') 
    117 excludes.append('IPython') 
    118 excludes.append('PyQt4') 
    119 excludes.append('PySide') 
    120 excludes.append('Qt4') 
    121 excludes.append('Tkinter') 
    122 excludes.append('tk') 
    123 excludes.append('tcl') 
    124 # Seems we cannot build on Linux without bundling sip 
    125 if not platform.system() == 'Linux': 
    126     excludes.append('sip') 
    127 excludes.append('sympy') 
    128 excludes.append('pytz') 
    129 excludes.append('sklearn') 
    130 excludes.append('zmq') 
    131102 
    132103# Need to explicitly exclude sasmodels here!! 
     
    138109 'sasmodels.core', 
    139110 'pyopencl', 
    140  'tinycc' 
     111 'tinycc', 
     112 'SocketServer' 
    141113] 
    142114 
Note: See TracChangeset for help on using the changeset viewer.