Version 2 (modified by smk78, 4 years ago) (diff)

Setting up a Windows IDE in Eclipse

(with thanks to Pete Jemian, APS)

NB: Eclipse requires Java SE!

  • This section is optional, if you want to use an IDE like Eclipse and not a text editor like Vim then carry on reading.
  • Read the instruction on how I did it below or follow this simple guide by Pete Jemian.
  • This section will explain how to set up SasView in Eclipse because it's the most commonly used open-source IDE. Get a copy and install it on your computer. http://www.eclipse.org/downloads/
  • Once these are installed load up Eclipse. It will ask for a workspace directory to store the project files in, you can choose anywhere.
  • Make sure that you are in PyDev mode. You can see this in the top right corner of Eclipse.
  • Setup a new project. File ‣ New ‣ PyDev Project. Name it something sensible like SasView? Project. Leave all options as default but make sure the option "Create 'src' folder and add it to the PYTHONPATH" is selected.
  • Then, you have to go to File ‣ Import, and choose the File System option:

http://1.bp.blogspot.com/_SDci0Pf3tzU/SVokhZBDNfI/AAAAAAAAEbg/_2sVRjA-PCM/s400/Import+Eclipse.jpg

  • Select the directory where your files are located and the input Folder, and click finish.
  • Add the directory where the external packages are stored to the PyDev settings. Window ‣ Preferences ‣ PyDev ‣ Interpreter-Python ‣ Libraries ‣ New Folder.
  • If you still have errors with wxPython then remove your interpreter and add it again. After a restart of Eclipse the errors should have disappeared.
  • Finally right click on the project, properties and then change the PyDev PYTHONPATH so that it contains the build directory. This is needed for debugging purposes.
  • Open sansview.py and hit the run button.

http://i.imgur.com/DTu5A.png