Ignore:
File:
1 edited

Legend:

Unmodified
Added
Removed
  • installers/sasview_qt5_osx.spec

    r44753d6 r2ae3edb  
    7070datas.append((os.path.join(PYTHON_LOC,'plugins','platforms'),'platforms')) 
    7171#TRN datas.append((os.path.join(PYTHON_LOC,'Lib','site-packages','zmq','libzmq.cp36-win_amd64.pyd'),'.')) 
    72 datas.append((os.path.join(PYTHON_LOC,'lib','python3.6', 'site-packages','zmq','libzmq.cpython-36m-darwin.so'),'.')) 
     72datas.append((os.path.join(PYTHON_LOC,'lib','python3.6', 'site-packages','zmq'),'.')) 
    7373# These depend on whether we have MKL or Atlas numpy 
    74 if os.path.exists(os.path.join(LIBLOC, LIBPREFIX + 'mkl_core.' + LIBSUFFIX)): 
    75     datas.append(add_binary(LIBPREFIX + 'mkl_avx2.' + LIBSUFFIX)) 
    76     datas.append(add_binary(LIBPREFIX + 'mkl_core.' + LIBSUFFIX)) 
    77 elif os.path.exists(os.path.join(LIBLOC, LIBPREFIX + 'numpy-atlas.' + LIBSUFFIX)): 
    78     datas.append(add_binary(LIBPREFIX + 'numpy-atlas.' + LIBSUFFIX)) 
    79 else: 
    80     raise Exception("No numerical library for numpy found.") 
     74#if os.path.exists(os.path.join(LIBLOC, LIBPREFIX + 'mkl_core.' + LIBSUFFIX)): 
     75#    datas.append(add_binary(LIBPREFIX + 'mkl_avx2.' + LIBSUFFIX)) 
     76#    datas.append(add_binary(LIBPREFIX + 'mkl_core.' + LIBSUFFIX)) 
     77#elif os.path.exists(os.path.join(LIBLOC, LIBPREFIX + 'numpy-atlas.' + LIBSUFFIX)): 
     78#    datas.append(add_binary(LIBPREFIX + 'numpy-atlas.' + LIBSUFFIX)) 
     79#else: 
     80#    raise Exception("No numerical library for numpy found.") 
    8181 
    8282#import sas.sascalc.dataloader.readers 
Note: See TracChangeset for help on using the changeset viewer.