source: sasview/build_tools/conda_qt5_min_ubuntu.yml @ a22b77a

ESS_GUIESS_GUI_bumps_abstractionESS_GUI_iss1116ESS_GUI_openclESS_GUI_sync_sascalc
Last change on this file since a22b77a was a22b77a, checked in by Piotr Rozyczko <piotr.rozyczko@…>, 16 months ago

Explicit dependencies for minimum installation. Fixes broken Ubuntu
builds and is the first attempt at SASVIEW-1250

  • Property mode set to 100644
File size: 531 bytes
Line 
1name: qt5_ubuntu
2channels:
3 - conda-forge
4dependencies:
5 - matplotlib=2.2.2
6 - scipy=1.1.0
7 - hdf5=1.10.1
8 - h5py=2.8.0
9 - ipython=6
10 - ipykernel=4.9
11 - jupyter
12 - twisted=18.4.0
13 - lxml=4.2.1
14 - sphinx=1.7.4
15 - cython=0.28.3
16 - pytest
17 - mako=1.0.7
18 - pyinstaller=3.3.1
19 - pyqt>=5.9 # required for GTK themes to work correctly
20 - testpath=0.3.1
21 - numpy=1.14.3  # NEED TO DOWNGRADE NUMPY!!!
22# - pyopencl
23# - pocl
24 - pip:
25   - pytools==2018.4
26   - periodictable==1.5.0
27   - bumps==0.7.8
28   - xhtml2pdf==0.2.2
29   - qt5reactor==0.5
Note: See TracBrowser for help on using the repository browser.