Changes between Version 24 and Version 25 of DevNotes/CondaDevSetup


Ignore:
Timestamp:
Jun 5, 2018 12:33:46 PM (5 months ago)
Author:
richardh
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • DevNotes/CondaDevSetup

    v24 v25  
    6161 
    6262}}} 
    63 == [=#anchor1 Step 6 - try the new qt gui (highly experimental work in progress)] == 
    64 ''Some notes as of 18 Jan 2018 based on a Windows 7 install. Start with Git bash in your sasview directory.'' 
     63== [=#anchor1 Step 6 - try the new qt gui (work in progress)] == 
     64''Some notes, updated 5th June 2018, based on a Windows 7 install. Start with Git bash in your sasview directory.'' 
    6565 
    6666source deactivate 
     
    6868git checkout ESS_GUI 
    6969 
    70 ''Look for sasview/build_tools/conda_py3_qt5_env.yml, open it in an editor, save it somewhere else outside of git control, '''remove''' any pip lines for sasview and sasmodels which will elsewise throw errors. '' 
     70''Look for sasview/build_tools/conda_py3_qt5_env.yml, open it in an editor, save it somewhere else outside of git control, '''remove''' in the pip section the lines for sasview and sasmodels, then '''add '''there - tinycc==1.1 the compiler for the models.'' 
    7171 
    72 conda env create -f=/path to your new yml file/conda_py3_qt5_env_new.yml 
     72''[Note - if later whilst running sasview you have problems with models not compiling or loading, close sasview, delete the contents of the directory users/your-user-name/sasmodels/compiled_models, then re-start, which will force re-compilation using the current compiler.]'' 
     73 
     74conda env create -f=/path-to-your-new-yml-file/conda_py3_qt5_env_new.yml 
    7375 
    7476source activate qt5 
     
    8284python run.py 
    8385 
    84 ''If run.py gives an error from line 1140 in readCategoryInfo, you likely have the old version of the categories file. Delete the file serial_cat.json from your user directory (C:\<username>\.sasview\ in Windows) and then run the latest *release* version of sasview. This will automatically generate the correct categories.json file.'' 
     86''If run.py gives an error from line 1140 in readCategoryInfo, you likely have the old version of the categories file. Delete the file serial_cat.json from your user directory  ( c:/users/username/.sasview in Windows) and then run the latest *release* version of sasview. This will automatically generate the correct categories.json file.'' 
    8587 
    8688''You may then need to install 64 bit Microsoft Visual C++ 14.0 compiler by following the link requested, as the latest changes to use only TinyCC compiler are not yet merged with this branch. Other useful conda commands:''