Changeset 56dd23c in sasview


Ignore:
Timestamp:
Feb 2, 2019 12:03:55 PM (16 months ago)
Author:
wojciech
Branches:
ESS_GUI, ESS_GUI_bumps_abstraction, ESS_GUI_iss1116, ESS_GUI_opencl, ESS_GUI_sync_sascalc
Children:
99ed727
Parents:
e2083f1a (diff), 8e76e49 (diff)
Note: this is a merge changeset, the changes displayed below correspond to the merge itself.
Use the (diff) links above to see all the changes relative to each parent.
Message:

Merge branch 'ESS_GUI' of https://github.com/SasView/sasview into ESS_GUI

Files:
5 edited

Legend:

Unmodified
Added
Removed
  • build_tools/conda_qt5_min_ubuntu.yml

    r00fd278 ra22b77a  
    33 - conda-forge 
    44dependencies: 
    5  - matplotlib=2 
    6  - scipy 
    7  - hdf5 
    8  - h5py 
    9  - ipython 
     5 - matplotlib=2.2.2 
     6 - scipy=1.1.0 
     7 - hdf5=1.10.1 
     8 - h5py=2.8.0 
     9 - ipython=6 
    1010 - ipykernel=4.9 
    1111 - jupyter 
    12  - twisted 
    13  - lxml 
    14  - sphinx 
    15  - cython 
     12 - twisted=18.4.0 
     13 - lxml=4.2.1 
     14 - sphinx=1.7.4 
     15 - cython=0.28.3 
    1616 - pytest 
    17  - mako 
    18  - pyinstaller  
     17 - mako=1.0.7 
     18 - pyinstaller=3.3.1  
    1919 - pyqt>=5.9 # required for GTK themes to work correctly 
    2020 - testpath=0.3.1 
     21 - numpy=1.14.3  # NEED TO DOWNGRADE NUMPY!!! 
    2122# - pyopencl 
    2223# - pocl 
    2324 - pip: 
    24    - pytools  
    25    - periodictable  
    26    - bumps  
    27    - xhtml2pdf  
    28    - qt5reactor  
     25   - pytools==2018.4 
     26   - periodictable==1.5.0 
     27   - bumps==0.7.8 
     28   - xhtml2pdf==0.2.2 
     29   - qt5reactor==0.5 
  • build_tools/conda_qt5_ubuntu.yml

    rdf44689 re9b115aa  
    2323  - cryptography=2.2.1=py36_0 
    2424  - cycler=0.10.0=py36_0 
    25   - dbus=1.11.0=0 
     25  - dbus 
    2626  - decorator=4.3.0=py_0 
    2727  - docutils=0.14=py36_0 
     
    3030  - freetype=2.8.1=0 
    3131  - gettext=0.19.8.1=0 
    32   - glib=2.55.0=0 
    33   - gst-plugins-base=1.8.0=0 
    34   - gstreamer=1.8.0=1 
     32  - glib=2 
     33  - gst-plugins-base 
     34  - gstreamer 
    3535  - h5py=2.8.0=py36h470a237_0 
    3636  - hdf5=1.10.1=2 
     
    4444  - libpng=1.6.34=0 
    4545  - libsodium=1.0.16=0 
    46   - libtiff=4.0.9=0 
     46  - libtiff 
    4747  - libxcb=1.13=0 
    4848  - libxslt=1.1.32=0 
     
    5151  - mako=1.0.7=py36_0 
    5252  - markupsafe=1.0=py36_0 
    53   - matplotlib=2.2.2=py36_1 
     53  - matplotlib=2 
    5454  - ncurses=5.9=10 
    5555  - ocl-icd=2.2.9=4 
    5656  - openblas=0.2.20=7 
    57   - openssl=1.0.2o=0 
     57  - openssl 
    5858  - packaging=17.1=py_0 
    5959  - pcre=8.41=1 
     
    6666  - pyopenssl=18.0.0=py36_0 
    6767  - pyparsing=2.2.0=py36_0 
    68   - pyqt=5.6.0=py36_5 
     68  - pyqt>=5.9.0 
    6969  - pysocks=1.6.8=py36_1 
    70   - python=3.6.5=1 
     70  - python=3.6 
    7171  - python-dateutil=2.7.3=py_0 
    7272  - pytools=2018.4=py_0 
    7373  - pytz=2018.4=py_0 
    74   - qt=5.6.2=7 
     74  - qt>=5.9 
    7575  - readline=7.0=0 
    7676  - requests=2.18.4=py36_1 
    7777  - setuptools=39.2.0=py36_0 
    78   - sip=4.18=py36_1 
    79   - six=1.11.0=py36_1 
     78  - sip 
     79  - six>=1.11.0=py36_1 
    8080  - snowballstemmer=1.2.1=py36_0 
    8181  - sphinx=1.7.4=py36_0 
    8282  - sphinxcontrib-websupport=1.0.1=py36_0 
    83   - sqlite=3.20.1=2 
     83  - sqlite 
    8484  - tk=8.6.7=0 
    8585  - tornado=5.0.2=py36_0 
     
    103103  - scipy=1.1.0=py36hfc37229_0 
    104104  - service_identity=17.0.0=py36_0 
     105  - jedi=0.12.1 
    105106  - pip: 
    106107    - automat==0.6.0 
  • build_tools/jenkins_ubuntu_build.sh

    r1095866 r8e76e49  
    1818cd build_tools 
    1919conda env create --force -f conda_qt5_min_ubuntu.yml 
     20# conda env create --force -f conda_qt5_ubuntu.yml 
    2021conda env list 
    2122 
  • installers/sasview_qt5_min_centos.spec

    r4e85147 ra22b77a  
    8383# else: 
    8484#     raise Exception("No numerical library for numpy found.") 
    85 #  
     85 
    8686 
    8787#import sas.sascalc.dataloader.readers 
     
    153153 'site','lxml._elementpath','lxml.etree', 
    154154 'scipy._lib.messagestream', 
     155 'IPython', 
    155156] 
    156157 
  • build_tools/conda_qt5_osx.yml

    r2c2621b re2083f1a  
    1 name: qt5_osx 
     1name: qt5_osx_beta 
    22channels: 
    3   - diffpy 
    4   - rpmuller 
    53  - conda-forge 
    64  - intel 
    7   - defaults 
    85dependencies: 
    9   - alabaster=0.7.10=py36_1 
    106  - altgraph=0.15=py_0 
    11   - appdirs=1.4.3=py_0 
    12   - attrs=18.1.0=py_0 
    13   - automat=0.6.0=py36_0 
    14   - babel=2.6.0=py36_0 
    15   - backports.functools_lru_cache=1.5=py36_0 
    16   - ca-certificates=2018.4.16=0 
    17   - certifi=2018.4.16=py36_0 
    18   - clangdev=6.0.0=default_0 
    19   - colorama=0.3.9=py36_0 
    20   - constantly=15.1.0=py_0 
    21   - coverage=4.5.1=py36_0 
    227  - cython=0.28.3=py36_0 
    23   - docutils=0.14=py36_0 
    248  - h5py=2.8.0=py36h470a237_0 
    25   - hyperlink=17.3.1=py_0 
    269  - hypothesis=3.57.0=py36h24bf2e0_0 
    27   - icu=58.2=0 
    28   - imagesize=1.0.0=py36_0 
    29   - incremental=17.5.0=py_0 
    30   - jpeg=9b=2 
    31   - libcxx=6.0.0=0 
    32   - libgfortran=3.0.0=0 
    33   - libxslt=1.1.32=0 
    34   - llvm-meta=6.0.0=0 
    35   - llvmdev=6.0.0=default_2 
    3610  - lxml=4.2.1=py36_0 
    3711  - macholib=1.8=py_0 
    3812  - mako=1.0.7=py36_0 
    39   - ncurses=5.9=10 
    4013  - openssl=1.0.2o=0 
    4114  - packaging=17.1=py_0 
    42   - pyasn1=0.4.2=py_0 
    43   - pyasn1-modules=0.2.1=py_0 
    4415  - pycrypto=2.6.1=py36_1 
    4516  - pyinstaller=3.3.1=py36_0 
    46   - pympler=0.5=py36_0 
    4717  - pyqt=5.6.0=py36_5 
    4818  - pytools=2018.4=py_0 
    4919  - qt=5.6.2=h9e3eb04_4 
    5020  - qtconsole=4.3.1=py36_0 
    51   - readline=7.0=0 
    52   - sip=4.18=py36_1 
    53   - snowballstemmer=1.2.1=py36_0 
    5421  - sphinx=1.7.4=py36_0 
    55   - sphinxcontrib-websupport=1.0.1=py36_0 
    56   - tbb=2018_20171205=0 
    57   - typing=3.6.4=py36_0 
    58   - intel-openmp=2018.0.0=8 
    5922  - service_identity=17.0.0=py36_0 
    6023  - twisted=17.5.0=py36_0 
    61   - zope=1.0=py36_0 
    62   - zope.interface=4.5.0=py36h1de35cc_0 
    63   - periodictable=1.5.0=py36_0 
    64   - appnope=0.1.0=py36_intel_5 
    65   - asn1crypto=0.24.0=py36_intel_1 
    66   - backcall=0.1.0=py36_intel_0 
    67   - backports=1.0=py36_intel_6 
    68   - bzip2=1.0.6=intel_14 
    69   - cffi=1.11.5=py36_intel_1 
    70   - chardet=3.0.4=py36_intel_0 
    71   - cryptography=2.2.2=py36_intel_1 
    72   - cycler=0.10.0=py36_intel_5 
    73   - decorator=4.3.0=py36_intel_0 
    74   - freetype=2.9=intel_1 
    75   - get_terminal_size=1.0.0=py36_intel_5 
    7624  - hdf5=1.10.1=intel_0 
    77   - icc_rt=2018.0.3=intel_0 
    78   - idna=2.6=py36_intel_0 
    79   - intelpython=2018.0.3=0 
    8025  - ipykernel=4.6.1=py36_intel_0 
    8126  - ipython=6.3.1=py36_intel_1 
    82   - ipython_genutils=0.2.0=py36_intel_0 
    83   - jedi=0.12.0=py36_intel_0 
    84   - jinja2=2.9.6=py36_intel_0 
    8527  - jupyter_client=5.1.0=py36_intel_0 
    8628  - jupyter_core=4.4.0=py36_intel_1 
    87   - kiwisolver=1.0.1=py36_1 
    88   - libffi=3.2.1=intel_8 
    89   - libpng=1.6.34=intel_1 
    90   - markupsafe=1.0=py36_intel_0 
    9129  - matplotlib=2.2.2=np114py36_intel_1 
    92   - mkl=2018.0.3=intel_1 
    93   - mkl_fft=1.0.2=np114py36_intel_0 
    94   - mkl_random=1.0.1=np114py36_intel_0 
    9530  - numpy=1.14.3=py36_intel_0 
    96   - openmp=2018.0.3=intel_0 
    97   - parso=0.2.0=py36_intel_0 
    98   - path.py=11.0.1=py36_intel_0 
    99   - pexpect=4.2.1=py36_intel_1 
    100   - pickleshare=0.7.4=py36_intel_1 
    101   - pip=9.0.3=py36_0 
    102   - prompt_toolkit=1.0.15=py36_intel_0 
    103   - ptyprocess=0.5.2=py36_intel_0 
    104   - pycparser=2.18=py36_intel_0 
    105   - pygments=2.2.0=py36_intel_1 
    106   - pyopenssl=17.5.0=py36_intel_0 
    10731  - pyparsing=2.2.0=py36_intel_0 
    10832  - pysocks=1.6.7=py36_intel_0 
    10933  - python=3.6.3=intel_12 
    110   - python-dateutil=2.6.0=py36_intel_3 
    111   - pytz=2018.4=py36_intel_0 
    112   - pyzmq=16.0.2=py36_intel_4 
    113   - requests=2.18.4=py36_intel_0 
    11434  - scipy=1.0.1=np114py36_intel_3 
    11535  - setuptools=39.0.1=py36_0 
    116   - simplegeneric=0.8.1=py36_intel_5 
    117   - six=1.11.0=py36_2 
    118   - sqlite=3.23.1=intel_0 
    119   - tcl=8.6.4=intel_19 
    120   - tk=8.6.4=intel_26 
    121   - tornado=4.5.2=py36_intel_0 
    122   - traitlets=4.3.2=py36_intel_1 
    123   - urllib3=1.22=py36_intel_0 
    124   - wcwidth=0.1.7=py36_intel_5 
     36  - six=1.11.0 
    12537  - wheel=0.31.0=py36_intel_0 
    126   - xz=5.2.3=intel_0 
    127   - zlib=1.2.11=intel_3 
    128   - pyquante2_pure=2.0=py_0 
    12938  - pyopencl=2018.1.1 
     39  - automat=0.6.0=py36_0 
     40  - ca-certificates=2018.4.16=0 
     41  - certifi=2018.4.16=py36_0 
     42  - libcxx=6.0.0=0 
     43  - llvm-meta=6.0.0=0 
     44  - mkl=2018.0.3=intel_1 
     45  - pip=9.0.3=py36_0 
     46  - tbb=2018_20171205=0 
     47  - cffi=1.11.5=py36_intel_1 
     48  - requests=2.18.4=py36_intel_0 
     49  - imagesize=1.0.0=py36_0 
     50  - zope.interface=4.5.0=py36h1de35cc_0 
     51  - attrs=18.1.0=py_0 
     52  - alabaster=0.7.10=py36_1 
     53  - sphinxcontrib-websupport=1.0.1=py36_0 
     54  - coverage=4.5.1=py36_0 
     55  - jpeg=9b=2 
     56  - pyasn1=0.4.2=py_0 
     57  - pyasn1-modules=0.2.1=py_0 
    13058  - pip: 
    13159    - backports.shutil-get-terminal-size==1.0.0 
     
    13664    - pillow==5.1.0 
    13765    - pypdf2==1.26.0 
    138     - pyquante2==0.1 
    13966    - qt5reactor==0.5 
    14067    - reportlab==3.4.0 
    14168    - webencodings==0.5.1 
    14269    - xhtml2pdf==0.2.2 
    143  
Note: See TracChangeset for help on using the changeset viewer.